[gnome-bluetooth] building 0.7.0

Johan Claesson johanclaesson at bredband.net
Sun Jan 8 13:26:07 GMT 2006


I have problems installing gnome-bluetooth on my debian (stable/sarge)
system. It maybe is related to the use of the --prefix option to
configure, but i am not sure. Initially i run 

> ./configure --prefix=/alien
> make
> make install

When i try to start it the following happens.

> gnome-bluetooth-manager
/usr/bin/python: can't open file

I looked at the make install log and found that
most of the software were installed under /alien but there was a
exception. Some python files ended up
in /usr/alien/lib/python2.3/site-packages/gnomebt.
After that i tried to run ./configure without the --prefix option.
Then they ended up
in /usr/usr/local/lib/python2.3/site-packages/gnomebt/.

I tried to workaround this by soft linking.

/usr/lib/python2.3/site-packages:0# ln
-s /usr/alien/lib/python2.3/site-packages/gnomebt 

That seem to make it find maganger.py but there is another problem.

> gnome-bluetooth-manager
Fatal Python error: can't initialise module controller



More information about the gnome-bluetooth mailing list