[gnome-bluetooth] gnome-bluetooth make error

Rob Vleeshouwers rvl at imtf.ch
Fri Jul 2 10:46:45 BST 2004

I'm trying to compile gnome-bluetooth 0.5.1 on RH 9.0 but get below
error when running make.

"controller.gob: In function `gnomebt_controller_remove_device':
controller.gob:337: `GCONF_UNSET_INCLUDING_SCHEMA_NAMES' undeclared
(first use in this function)
controller.gob:337: (Each undeclared identifier is reported only once
controller.gob:337: for each function it appears in.)
make[2]: *** [gnomebt-controller.lo] Error 1
make[2]: Leaving directory `/home/rvl/gnome-bluetooth-0.5.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/rvl/gnome-bluetooth-0.5.1'
make: *** [all-recursive-am] Error 2

I have seen the exact same error already reported by someone else but
didn't find any solution yet.

I tried gnome-bluetooth 0.4 as well and I can run the gnome-obex-server.
I can send files from my phone to the workstation but nautilus crashes
when I try to browse for bluetooth devices.  

When I'm trying gnome-bluetooth-admin I get following error:

** (gnome-bluetooth-admin:11238): WARNING **: Couldn't get instance of
BT Manager

On the terminal running gnome-bluetooth-control I get:

relocation error: ./gnome-bluetooth-control: undefined symbol:

Bluetooth is working for me as I'm able to sync my P900 with evolution
over bluetooth.

Any help would be appreciated.


Rob Vleeshouwers.

More information about the gnome-bluetooth mailing list