[gnome-bluetooth] Nokia 6820 problems with gnome-obex-server

Diana Galletly dag1000 at eng.cam.ac.uk
Wed May 26 13:16:34 BST 2004

On Wed, 26 May 2004, Pete Setchell wrote:

> I've had a similar problem on Debian x86 with a Nokia 6600 - it was
> solved by making the following /etc/bluetooth/hcid.conf change:
>         # Local device class
>         class 0x100100;
> Make sure you've restarted the bluez services after making the change.

Yes, I'd already tried that ...

> This is normal behaviour while it waits for an incoming file.

But without starting up a GUI of any sort?  Colour me naive, but I'd
kind of expected something that prefaced itself with "gnome" to have
at least a minimal GUI .... ;-)

> There is also an obexserver package in Debian which also works with my
> nokia. It isn't as nice, but might help isolate a bug in g-o-s from one
> in the shared libraries. You need to register the OPUSH protocol with
> "sdptool add --channel=10 OPUSH", then run "./obexserver" and you should
> be able to push a file from the phone.

Aha!  Now _that_ does work fine.  Thankfully I'm not particularly fussed
about GUIs and can cope Just Fine with CLIs, so I can get my data perfectly
happily off the phone now.

So I wonder what's going on with gnome-obex-server ...

Many thanks for your help!


More information about the gnome-bluetooth mailing list