[gnome-bluetooth] ./configure error for gnome-bluetooth-0.5.1

Ben Van Mechelen ben at vmechelen.net
Thu Jun 9 11:57:37 BST 2005

Al wrote:
> Hi, there:
>      I already ./configure, make, and make install 
> for libbtctl-0.4.1 in advance. It works OK.
>      Then I encounter error for running ./configure for gnome-bluetooth-0.5.1. Any idea?
> thanks a lot
> Al
> ================================================================
> Using $(sysconfdir)/gconf/schemas/ as install directory for schema files
> checking for gob2... /usr/bin/gob2
> checking for gob-2 >= 2.0.0... ok
> checking for pkg-config... (cached) /usr/bin/pkg-config
> checking for glib-genmarshal... /usr/bin/glib-genmarshal
> checking for libglade-2.0 gobject-2.0 libgnomeui-2.0 >= 1.110.0 gconf-2.0 libbtctl >= 0.4... Requested 'libbtctl >= 0.4' but version of libbtctl is 0.3
> configure: error: Library requirements (libglade-2.0 gobject-2.0 libgnomeui-2.0 >= 1.110.0 gconf-2.0 libbtctl >= 0.4) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

Did you install libbtctl-0.4.1 in the same prefix as your old 0.3? if
not, it's possible that pkg-config finds your old library first. And
then it won't look any further (I think).


More information about the gnome-bluetooth mailing list