[gnome-bluetooth] obex-data-server from command line

Bastien Nocera hadess at hadess.net
Tue Sep 30 14:52:17 CEST 2008

On Tue, 2008-09-30 at 13:35 +0200, Per Thomas Jahr wrote:
> Hi, 
> How can I run the obex-data-server from the command line and get it to
> register services properly? I have tried this:
> $ /usr/bin/obex-data-server --no-daemon
> ** Message: obex-data-server 0.3.1
> ** Message: Using Session bus

obex-data-server is a D-Bus service, not a stand-alone daemon.

> However, if I start the server from the gnome-file-share-properties UI,
> it will register correctly:
> $ sdptool browse local | grep -i obex
> Service Name: OBEX Object Push
>   "OBEX Object Push" (0x1105)
>   "OBEX" (0x0008)
>   "OBEX Object Push" (0x1105)
> What does the last approach do differently and how can I make it work
> from the command line?

It already works "from the command-line". gnome-file-share-properties
will launch gnome-user-share which will setup the D-Bus service
according to the user settings.

It still requires an X server to display notifications obviously...

More information about the gnome-bluetooth mailing list