[phpxmlrpc] Request timeouts

Jeff Tupholme jeff-lists at makemyshow.com
Fri May 5 23:21:57 BST 2006


I'm having problems with a long-running complex query to my XML-RPC 
server timing out. Initially I was getting the PHP error 'Maximum 
execution time of 30 seconds exceeded', so I changed 
'max_execution_time' in php.ini to 60 and that went away.

However, it was replaced with a message of 'No response received from 
server', which appeared after exactly 60 seconds. I tried increasing 
'max_execution_time' again but to no avail, and I've also tried 
changing 'default_socket_timeout' and even 'max_input_time' up to 90 
but still get the same result after 60 seconds. Therefore I think it's 
being constrained by something else.

I'm not specifying a timeout in my client send method, but I also tried 
that at 90 with no change. I'm running the client from the command 
line. If I change the values I pass to the method to make the 
underlying query simpler and quicker it works.

Any ideas what I really need to change to allow my long query to 
complete, please?



More information about the phpxmlrpc mailing list